Road Star Forum
Welcome, Guest
Please Login or Register.    Lost Password?
Go to bottom Post Reply Favoured: 0
TOPIC: Re:Starter relay questions
#1014604
cmw2212 (User)
Junior Boarder
Posts: 154
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Location: Fayetteville, NC Birthdate: 1976-02-12
Starter relay questions 5 Months ago  
So the pictures below are of the relay that was on my R*. It has seen better days but beyond that it doesn't look anything like the ones that pop up when I am looking for a replacement. I put everything back together and now have no power when I turn the key. I used my voltmeter and I have power going into the relay but nothing coming out to the harness. I bypassed the relay and got power to everything so I am pretty sure the relay has failed internally.

Am I correct in thinking this isn't the original relay for the R*?
Second, would an internal failure be the only reason it wouldn't be passing power to the harness?




 
Logged Logged  
 
Last Edit: 2017/06/19 10:28 By cmw2212.
  The administrator has disabled public write access.
#1014605
txulrich (User)
Platinum Boarder
Posts: 2688
graphgraph
User Online Now Click here to see the profile of this user
Gender: Male Location: Dallas, TX Birthdate: 1957-04-21
Re:Starter relay questions 5 Months ago  
Based on the 2nd picture, I can definitely say that relay is toast.
 
Logged Logged  
 
Peace,
Baron Wilhelm Gustav von Schmidtt III
(but you can call me Joe)

  The administrator has disabled public write access.
#1014606
Xthread13 (User)
Fresh Boarder
Posts: 4
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Location: FT. Smith Ar
Re:Starter relay questions 5 Months ago  
dont look like it to me
 
Logged Logged  
  The administrator has disabled public write access.
#1014608
cmw2212 (User)
Junior Boarder
Posts: 154
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Location: Fayetteville, NC Birthdate: 1976-02-12
Re:Starter relay questions 5 Months ago  
txulrich wrote:
Based on the 2nd picture, I can definitely say that relay is toast.


And the kicker is, it was working fine before I started my rebuild project.
 
Logged Logged  
  The administrator has disabled public write access.
#1014612
txulrich (User)
Platinum Boarder
Posts: 2688
graphgraph
User Online Now Click here to see the profile of this user
Gender: Male Location: Dallas, TX Birthdate: 1957-04-21
Re:Starter relay questions 5 Months ago  
Xthread13 wrote:
dont look like it to me

It may not look like toast, but with the windings exposed a hard failure was only a matter of time.
 
Logged Logged  
 
Peace,
Baron Wilhelm Gustav von Schmidtt III
(but you can call me Joe)

  The administrator has disabled public write access.
Go to top Post Reply
Powered by FireBoardget the latest posts directly to your desktop
...................................................................... ...................................................................... ...................................................................... ...................................................................... ...................................................................... ...................................................................... ...................................................................... ...................................................................... ...................................................................... -->
New Forum Posts




The Road Star Clinic is a collaborative community of riders who archive and publish user contributed technical data about Yamaha Road Star motorcycles.

We also sponsor the creation and support of other community websites similar to our own. Inquiries about availability of a website for your community can be submitted to us via any "Contact Us" option on the Clinic.

Copyright 2003-2007 Road Star Clinic and its respective authors. Road Star Clinic is sponsored by the folks at MLSHomeQuest.com.